iframe calendar google non fonctionnel

par -thierry-, vendredi 30 octobre 2015, 15:27 (il y a 127 jours)

Bonjour,
Je cherche à inclure un agenda Google dans un site 99Ko.
Je passe via un iframe mais la page refuse de s'afficher dans ce dernier.

Savez-vous pourquoi ?

Merci.

iframe calendar google non fonctionnel

par 99ko @, mardi 03 novembre 2015, 22:07 (il y a 122 jours) @ -thierry-

Tu peux donner plus de détail sur la manip ou directement un lien ?

iframe calendar google non fonctionnel

par -thierry-, mercredi 04 novembre 2015, 13:28 (il y a 122 jours) @ 99ko

Bonjour,
Lorsque l'on dispose d'un agenda sous Google il est possible de faire générer le code qui inclut cet agenda dans un iframe : paramètres/Agendas/choisir l'agenda/intégrer cet agenda.

Ce qui donne dans mon cas :
"<iframe frameborder="0" height="600" scrolling="no" src="https://calendar.google.com/calendar/embed?src=qamsa3ivbjc8c4oduls6ilsveg%
40group.calendar.google.com&amp;ctz=Europe/Paris" style="border: 0px currentColor; border-image: none;" width="800"></iframe>"

J'ai copié le code généré dans une page Html hors 99ko et cela fonctionne bien.
Avec 99ko j'ai essayé deux approches :
1- Collage du code généré dans "source" de l'éditeur de la page
2- insertion du texte de l'URL dans le champ URL de "iframe" de l'éditeur de la page

Dans les deux cas l'iframe refuse de s'afficher dans la page.
Merci

iframe calendar google non fonctionnel

par 99ko @, mercredi 04 novembre 2015, 15:50 (il y a 122 jours) @ -thierry-

Tu as essayé de désactiver l'éditeur HTML dans les plugins avant de faire le copié collé ?

iframe calendar google non fonctionnel

par -thierry-, mercredi 04 novembre 2015, 18:03 (il y a 122 jours) @ 99ko

Merci pour la réponse, je viens d'essayer mais j'ai le même comportement...

iframe calendar google non fonctionnel

par manjarie, samedi 14 novembre 2015, 19:02 (il y a 112 jours) @ -thierry-

Bonjour,
Pour qu'un agendas Google s'affiche il faut le rendre public dans les paramètres de l'agendas sur le site de Google.
Dans mon cas après cette manip il s'affiche correctement.

iframe calendar google non fonctionnel

par -thierry-, samedi 14 novembre 2015, 19:11 (il y a 112 jours) @ manjarie

Bonjour,
Merci pour la réponse mais, l'aspect public va de soi, comme je l'ai indiqué j'ai l'habitude de fonctionner avec ce types de calendriers et le lien fonctionne d'ailleurs très bien sur une simple page Html (non 99ko).
Quelle version de 99ko utilises tu ?

iframe calendar google non fonctionnel

par manjarie, samedi 14 novembre 2015, 19:14 (il y a 112 jours) @ -thierry-

la dernière 2.4, je viens juste de l'installer, j'utilise 99ko pour la première fois.

iframe calendar google non fonctionnel

par -thierry-, samedi 14 novembre 2015, 21:13 (il y a 112 jours) @ manjarie

Avec cette version tu arrives à afficher un calendrier Google ?!
1- le plugin CKEditor est il installé ?
2- As tu simplement collé le code généré par Google ?
Merci

iframe calendar google non fonctionnel

par manjarie, lundi 16 novembre 2015, 16:42 (il y a 110 jours) @ -thierry-

J'affiche bien un agendas Google avec la version 2.4, avec le plugin CKEditor.

J'ai simplement collé le code généré par Google et ça marche.

Ensuite pour améliorer la présentation je l'ai inclus dans un div et modifié le CSS pour le rendre responsive.

Tu peux voir le résultat sur www.graindephonie.fr

iframe calendar google non fonctionnel

par -thierry-, lundi 16 novembre 2015, 17:11 (il y a 110 jours) @ manjarie

Bonjour,
Merci pour ton message.
Cela m'a permis de cibler davantage le problème mais sans le résoudre pour autant... En fait tu as le même problème, l'agenda n'apparaît pas dans 99ko sous IE (11 en l'occurrence sur mon ordi).
Par contre ton agenda, comme le mien apparaissent bien dans IE dès lors qu'ils sont dans une page Html classique hors 99ko.
J'ai essayé avec un iframe encapsulant une googlemaps et pas un agenda et là dans 99ko ça marche...
Je continue de fouiller.

iframe calendar google non fonctionnel

par manjarie, vendredi 20 novembre 2015, 09:10 (il y a 106 jours) @ -thierry-

Bonjour,
Je travaille sous Ubuntu, j'avais pas encore vérifié l'affichage sous IE.
Je viens de démarrer Windows et je n'ai pas de problème d'affichage sous IE 11...
Essaie de remettre IE à son état d'origine (Options Internet, Avancé, Réinitialiser...) tu as peut être une config ou un plugin qui empêche l'affichage correct des agendas.

Fil RSS du sujet
powered by my little forum